#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<year>\d{4})[\\\/](?<month>\d{2})(?:[\\\/](?<day>\d{2}))?$"
Local $sString = "somepath/yyyy/mm/dd" & @CRLF & _
"path/2014/10/12" & @CRLF & _
"path/2013/11" & @CRLF & _
"path\2014\01"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")