re = /(?<year>\d{4})[\\\/](?<month>\d{2})(?:[\\\/](?<day>\d{2}))?$/m
str = 'somepath/yyyy/mm/dd
path/2014/10/12
path/2013/11
path\\2014\\01'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end