import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<year>\\d{4})[\\\\\\/](?<month>\\d{2})(?:[\\\\\\/](?<day>\\d{2}))?$";
final String string = "somepath/yyyy/mm/dd\n"
+ "path/2014/10/12\n"
+ "path/2013/11\n"
+ "path\\2014\\01";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}