import re
regex = re.compile(r"(?<year>\d{4})[\\\/](?<month>\d{2})(?:[\\\/](?<day>\d{2}))?$", flags=re.MULTILINE)
test_str = ("somepath/yyyy/mm/dd\n"
"path/2014/10/12\n"
"path/2013/11\n"
"path\\2014\\01")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")