package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<year>\d{4})[\\\/](?<month>\d{2})(?:[\\\/](?<day>\d{2}))?$`)
var str = `somepath/yyyy/mm/dd
path/2014/10/12
path/2013/11
path\2014\01`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}