use strict;
my $str = 'somepath/yyyy/mm/dd
path/2014/10/12
path/2013/11
path\\2014\\01';
my $regex = qr/(?<year>\d{4})[\\\/](?<month>\d{2})(?:[\\\/](?<day>\d{2}))?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}