// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<year>\d{4})[\\\/](?<month>\d{2})(?:[\\\/](?<day>\d{2}))?$").unwrap();
let string = "somepath/yyyy/mm/dd
path/2014/10/12
path/2013/11
path\\2014\\01";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}