# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\h*Índice - \d+ -\h*/ /gm;t' <<< "This is a sentence Índice - 8 - forever
Just do it. Índice - 3 -"