package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\h*Índice - \d+ -\h*`)
var str = `This is a sentence Índice - 8 - forever
Just do it. Índice - 3 -`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}