// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\h*Índice - \d+ -\h*").unwrap();
let string = "This is a sentence Índice - 8 - forever
Just do it. Índice - 3 -";
let substitution = " ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}