#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\h*Índice - \d+ -\h*"
Local $sString = "This is a sentence Índice - 8 - forever" & @CRLF & _
"Just do it. Índice - 3 -"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)