const regex = /\h*Índice - \d+ -\h*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\h*Índice - \\d+ -\\h*', 'gm')
const str = `This is a sentence Índice - 8 - forever
Just do it. Índice - 3 -`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);