$re = '/\h*Índice - \d+ -\h*/m';
$str = 'This is a sentence Índice - 8 - forever
Just do it. Índice - 3 -';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;