use strict;
my $str = 'This is a sentence Índice - 8 - forever
Just do it. Índice - 3 -';
my $regex = qr/\h*Índice - \d+ -\h*/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";