using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\h*Índice - \d+ -\h*";
string substitution = @" ";
string input = @"This is a sentence Índice - 8 - forever
Just do it. Índice - 3 -";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}