#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\/users\/orders\/((?:[\w-]|\%\w{2})+)$"
Local $sString = "/users/orders/123" & @CRLF & _
"/users/orders/ads" & @CRLF & _
"/users/orders/13as" & @CRLF & _
"/users/orders/3-4sl%3F" & @CRLF & _
"/users/orders/34sl%%%%3F"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")