import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/users\\/orders\\/((?:[\\w-]|\\%\\w{2})+)$";
final String string = "/users/orders/123\n"
+ "/users/orders/ads\n"
+ "/users/orders/13as\n"
+ "/users/orders/3-4sl%3F\n"
+ "/users/orders/34sl%%%%3F";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}