re = /^\/users\/orders\/((?:[\w-]|\%\w{2})+)$/m
str = '/users/orders/123
/users/orders/ads
/users/orders/13as
/users/orders/3-4sl%3F
/users/orders/34sl%%%%3F'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end