package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/users\/orders\/((?:[\w-]|\%\w{2})+)$`)
var str = `/users/orders/123
/users/orders/ads
/users/orders/13as
/users/orders/3-4sl%3F
/users/orders/34sl%%%%3F`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}