const regex = /^\/users\/orders\/((?:[\w-]|\%\w{2})+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/users\\\/orders\\\/((?:[\\w-]|\\%\\w{2})+)$', 'gm')
const str = `/users/orders/123
/users/orders/ads
/users/orders/13as
/users/orders/3-4sl%3F
/users/orders/34sl%%%%3F`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}