// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\/users\/orders\/((?:[\w-]|\%\w{2})+)$").unwrap();
let string = "/users/orders/123
/users/orders/ads
/users/orders/13as
/users/orders/3-4sl%3F
/users/orders/34sl%%%%3F";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}