using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/users\/orders\/((?:[\w-]|\%\w{2})+)$";
string input = @"/users/orders/123
/users/orders/ads
/users/orders/13as
/users/orders/3-4sl%3F
/users/orders/34sl%%%%3F";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}