$re = '/^\/users\/orders\/((?:[\w-]|\%\w{2})+)$/m';
$str = '/users/orders/123
/users/orders/ads
/users/orders/13as
/users/orders/3-4sl%3F
/users/orders/34sl%%%%3F';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);