#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<N>[\+\-]\d*(\.\d+)?) (?<S>\[\w\]+)"
Local $sString = "+3.169834647 [%]" & @CRLF & _
"Serial correlation coefficient is -1.09487 (totally uncorrelated = 0.0)."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")