use strict;
my $str = '+3.169834647 [%]
Serial correlation coefficient is -1.09487 (totally uncorrelated = 0.0).';
my $regex = qr/(?<N>[\+\-]\d*(\.\d+)?) (?<S>\[\w\]+)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}