// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?<N>[\+\-]\d*(\.\d+)?) (?<S>\[\w\]+)").unwrap();
let string = "+3.169834647 [%]
Serial correlation coefficient is -1.09487 (totally uncorrelated = 0.0).";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}