import Foundation
let pattern = #"(?<N>[\+\-]\d*(\.\d+)?) (?<S>\[\w\]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
+3.169834647 [%]
Serial correlation coefficient is -1.09487 (totally uncorrelated = 0.0).
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}