package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<N>[\+\-]\d*(\.\d+)?) (?<S>\[\w\]+)`)
var str = `+3.169834647 [%]
Serial correlation coefficient is -1.09487 (totally uncorrelated = 0.0).`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}