re = /(?<N>[\+\-]\d*(\.\d+)?) (?<S>\[\w\]+)/
str = '+3.169834647 [%]
Serial correlation coefficient is -1.09487 (totally uncorrelated = 0.0).'
# Print the match result
str.match(re) do |match|
puts match.to_s
end