using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<N>[\+\-]\d*(\.\d+)?) (?<S>\[\w\]+)";
string input = @"+3.169834647 [%]
Serial correlation coefficient is -1.09487 (totally uncorrelated = 0.0).";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}