$re = '/(?<N>[\+\-]\d*(\.\d+)?) (?<S>\[\w\]+)/';
$str = '+3.169834647 [%]
Serial correlation coefficient is -1.09487 (totally uncorrelated = 0.0).';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);