#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:^|\G(?!^))(\w+),?\h(?=.*##(.+)$)"
Local $sString = "quirky, stable, fun ##Paul and Jill" & @CRLF & _
"mean, rude, sad, other ##Dave" & @CRLF & _
"rich, foolish ##Amanda"
Local $sSubst = "$2|$1##"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)