const regex = /(?:^|\G(?!^))(\w+),?\h(?=.*##(.+)$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|\\G(?!^))(\\w+),?\\h(?=.*##(.+)$)', 'gm')
const str = `quirky, stable, fun ##Paul and Jill
mean, rude, sad, other ##Dave
rich, foolish ##Amanda`;
const subst = `$2|$1##`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);