import Foundation
let pattern = ###"(?:^|\G(?!^))(\w+),?\h(?=.*##(.+)$)"###
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ###"""
quirky, stable, fun ##Paul and Jill
mean, rude, sad, other ##Dave
rich, foolish ##Amanda
"""###
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ###"$2|$1##"###
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)