import re
regex = re.compile(r"(?:^|\G(?!^))(\w+),?\h(?=.*##(.+)$)", flags=re.MULTILINE)
test_str = ("quirky, stable, fun ##Paul and Jill\n"
"mean, rude, sad, other ##Dave\n"
"rich, foolish ##Amanda")
subst = "$2|$1##"
result = regex.sub(subst, test_str)
if result:
print(result)