$re = '/(?:^|\G(?!^))(\w+),?\h(?=.*##(.+)$)/m';
$str = 'quirky, stable, fun ##Paul and Jill
mean, rude, sad, other ##Dave
rich, foolish ##Amanda';
$subst = "$2|$1##";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;