#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^https?:\/\/[w\d.]*([\S][^\/]+)"
Local $sString = "https://www.google.es/?gfe_rd=cr&ei=T5n6Va_qCdSp8wfljLSADg&gws_rd=ssl#q=generic+search"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")