// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^https?:\/\/[w\d.]*([\S][^\/]+)").unwrap();
let string = "https://www.google.es/?gfe_rd=cr&ei=T5n6Va_qCdSp8wfljLSADg&gws_rd=ssl#q=generic+search";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}