use strict;
my $str = 'https://www.google.es/?gfe_rd=cr&ei=T5n6Va_qCdSp8wfljLSADg&gws_rd=ssl#q=generic+search';
my $regex = qr/^https?:\/\/[w\d.]*([\S][^\/]+)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}