import re
regex = re.compile(r"^https?:\/\/[w\d.]*([\S][^\/]+)")
test_str = "https://www.google.es/?gfe_rd=cr&ei=T5n6Va_qCdSp8wfljLSADg&gws_rd=ssl#q=generic+search"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")