import Foundation
let pattern = #"^https?:\/\/[w\d.]*([\S][^\/]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"https://www.google.es/?gfe_rd=cr&ei=T5n6Va_qCdSp8wfljLSADg&gws_rd=ssl#q=generic+search"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
    let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
    print(result)
} else {
    print("No matches were found.")
}