# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:[A-Z]+|[A-Z][a-z]+)\K(?=[A-Z])/ /g;t' <<< "TodayILiveInTheUSAWithSimon"