use strict;
my $str = 'TodayILiveInTheUSAWithSimon';
my $regex = qr/(?:[A-Z]+|[A-Z][a-z]+)\K(?=[A-Z])/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";