re = /(?:[A-Z]+|[A-Z][a-z]+)\K(?=[A-Z])/
str = 'TodayILiveInTheUSAWithSimon'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result