using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[A-Z]+|[A-Z][a-z]+)\K(?=[A-Z])";
string substitution = @" ";
string input = @"TodayILiveInTheUSAWithSimon";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}