const regex = /(?:[A-Z]+|[A-Z][a-z]+)\K(?=[A-Z])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[A-Z]+|[A-Z][a-z]+)\\K(?=[A-Z])', 'g')
const str = `TodayILiveInTheUSAWithSimon`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);