$re = '/(?:[A-Z]+|[A-Z][a-z]+)\K(?=[A-Z])/';
$str = 'TodayILiveInTheUSAWithSimon';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;