import Foundation
let pattern = #"(?:[A-Z]+|[A-Z][a-z]+)\K(?=[A-Z])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"TodayILiveInTheUSAWithSimon"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)