#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:[A-Z]+|[A-Z][a-z]+)\K(?=[A-Z])"
Local $sString = "TodayILiveInTheUSAWithSimon"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)