# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\`\`\`\{r \')([A-Za-z0-9-\s]+)/**\2**\n\1\2/g;t' <<< "```{r '2b - Possible causes for discrepancy'}"